isu isu php 5.3

  Versi php 5.3 sebenarnya sudah lama release , sejalan dengan perkembangan pastinya system operasi akan mengikuti updatenya untuk include ke versi tersebut, khususnya pada system operasi linux.

Baru baru ini sudah mulai menonjol akan disibukan mengenai versi php tersebut, karena system operasi akan diupdate sesuai perkembangan terkini. Kini para penyedia layanan hosting perlahan akan memulai update systemnya ke versi php tersebut, mungkin dengan cara melakukan opsi jika aplikasi dibutuhkan versi php tersebut akan ada server baru dengan system operasi terupdate dengan versi php 5.3.

Contohnya pada hosting yang menggunakan kontrol panel Spanel, tempo hari pernah diberitakan pada blog resmi MWN rencana upgrade server share hosting Spanel ke ke Debian Squeeze (awal 2012) , saat ini perlahan sudah ada opsi server Spanel yang menggunakan Debian Squeez yang diinstallasikan pada server share hosting baru (dalam hal ini dengan versi php 5.3.x) yang kini sudah ada di setiap paket, untuk yang menggunakan Cpanel juga sudah ada, tanpa mengupgrade dahulu dari server share hosting yang sudah ada (server lama) , langkah awal ini dilakukan kemungkinan untuk menarik tren versi php 5.3 , setiap aplikasi perlu ada update dengan alasan sekuritas, pastinya nanti akan terupgrade semua system operasi ke Debian sequeeze, nantinya pasti akan ada info untuk tanggal mainnya, jadi bersiaplah untuk update pada aplikasi Anda untuk perubahan tersebut, mungkin Anda bisa komunikasikan hal ini kepada rekan programer atau menyewa jasa web maintener .

Isu isu apa saja yang terjadi pada aplikasi diversi php 5.3 sebagian sudah dijelaskan pada link petunjuk pada knowledgebase MWN , perbandingannya antara versi 5.2.x dan versi 5.3.x ,  php 5.3.x di deklarasi variable sama beberapa function < php 5.2 deprecated , maksud dari deprecated  adalah masih dapat digunakan , akan tetapi kemungkinan pada versi kedepan tidak akan support, misal, berlaku pada func request $_POST, $_GET, $_SESSION, $_COOKIE, dll :
– Fungsi-fungsi seperti ereg() alternatif digantikan preg_match()
– Deklarasi variable $xxx = $yyy dianggap notice pada php 5.3 alternatif digantikan if(isset($xxx)) { $xxx = $yyy; }
Selengkapnya bisa lihat pada link knowledgebase MWN .

Demikian Informasinya, semoga bermanfaat, kalau ada yang mau tambahkan mohon sharenya ;)

 

Leave a Reply